What's new
Embers Adrift

Register a free account today to Ignite your Adventure! Once signed in, you'll be able to participate with the Embers Adrift community. Your active account will also be the same account used to purchase, download, and login to the game.

Launcher stuck on Checking Local Files


New Member
After the latest update, which was downloaded seemingly without incident, my launcher now cannot get past "checking local files." I've tried using the repair function on the initial download app, deleting and re-downloading and restarting PC multiple times. After letting it run for 10 minutes or so it will freeze my PC. Have not downloaded anything or changed any PC settings since update this week.

Thanks for the help.
Windows or Mac?

Can't give Mac advice, perhaps others can advise, but I would suggest do the normal PC checks. Do a disk scan (chkdsk) for errors. Do a full anti-virus scan. Download any Windows and driver, graphics particularly, updates.
99% of the time this is an odd permissions problem that can be solved by running the launcher as admin.